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MMIC Front End for Solaria 

 

The MMIC Front End is essentially a preprocessor for Solaria.  A group of dialogs are used to define the 

geometry, materials, heat loads and boundary conditions of a power amplifier.  After the data has been 

defined, a complete ready-to-solve Solaria model is automatically built. 

 

Units 

In the process of defining the power amplifier, you will be selecting materials from the material library.  The 

data in the library is in a specific set of units.  For the units to be correct when the materials are applied to the 

model, the values need to be converted to your working units.  Therefore, you must first define those units.  

Select Model>Units.  Typically, it is easiest to work in linear units of Microns.  Simply select the units from the 

Predefined drop down.  The conversion factors will automatically filled in. 

 

 
 

Screen modes 

 

Solaria has several screen modes.  When Solaria is launched, you will be in the Solaria Model view mode.  You 

can select models you have generated in the past and solve and view results.  SolariaPCB is another 

preprocessor designed to model printed circuit boards.  If you are licensed for SolariaPCB, selecting the  

toolbar button will switch to SolariaPCB view mode. Any Solaria models that were on the screen will be 

cleared.  They are not deleted, they are just not viewed.  When you select the button again, you will be back in 

Solaria model mode and you will again see the model. 

 

Likewise, when you select Add>MMIC Front End, the view of a model on the screen will be cleared and you 

will be in MMIC view mode.  When you hit OK or Cancel to the dialog, you will again be in Solaria model view 

mode. 

 

 



Navigating in MMIC view mode 

These toolbar buttons can be used to change the view of the screen.   If you hold the left 

mouse button down and move the mouse, the view will be rotated.  Go to Settings>OpenGL>Display. There 

are two modes for this rotation.  Check Rotate freely on XYZ as this gives you the most control. 

 

If you double-click any place on the screen the following dialog will come up.  Here you can select more 

predefined views. 

 

 
The Main Dialog 

 

After launching Solaria, select Add>MMIC Front End.  Below is the main dialog from which all others are 

launched.   

 

 



 

Top substrate Material: The chip material is selected from the Material Library. 

Top substrate Height: This defines the thickness of the amplifier chip. 

Die Width (X Dimension): The width of the amplifier chip is defined. 

Die Length (Y Dimension): The height of the amplifier chip is defined. 

Base Temperature: Boundary Nodes are applied to the bottom of the bottom most Layer at this temperature. 

Applied Power Depth: The heat dissipated at the gate can be defined at the surface of the amplifier chip or at 

a depth below the surface. 

 
 

Save File button: This is used to save all data to a text based file.  The .fet type file is used by default. 

Read File button: This is used to read an existing amplifier data file with the .fet extension.   

Devices area: Power amplifier devices can be added, edited, deleted and copied.  To edit, delete or copy a 

device, first select the device from the drop-down list. 

Via area: Vias in the chip are defined.  The via plating material is selected from the Material Library.  The via 

can be filled with the selected material or unfilled.  Vias can be added, edited, deleted and copied.  To edit, 

delete or copy a via, first select the via from the drop-down list. 

Plating: Plating on the top or bottom of any Layer can be defined.  Hit the Edit button to add new plating or 

edit an existing one. 

Over Mold: Over mold can be defined by checking the Include checkbox.  Next select the Edit button to define 

the Material, thickness and select the layer defining the bottom location of the over mold. 

Air Bridge: Air bridges connecting Source and Drain metal can be defined.  Check the Include checkbox then 

select the Edit button to define the Material and thickness.  Source and Drain metallization must be defined to 

have air bridges. 

Layers:  Any number of layers can be added under the amplifier chip and attach.  Select the Add button to add 

a layer.  Select the Sort Layers button to define the order of the layers under the amplifier chip.  The default 

order is the order they were generated.  Layers can be edited, deleted and copied.  To edit, delete or copy a 

Layer, first select the Layer from the drop-down list. 

Surface Metallization: Metallization on the top surface of the amplifier chip can be added.  There is no limit to 

the quantity.  Select the Add button to add metallization.  Metallization can be edited, deleted and copied.  To 

edit, delete or copy a metallization, first select the metallization from the drop-down list. 

Location reference: When defining the location of the amplifier chip, it can be relative to the center or the 

lower left corner of the chip.   

Clear Existing Mesh button: If a mesh had already been defined by selecting the Mesh Geometry button, then 

this will clear the data.  This is used if the mesh parameters had been redefined. 

Mesh Geometry button: This is used to create the 2D model mesh as well as define the mesh structure 

through the thickness. 

Create Solaria Model button: This button is used after meshing the geometry to create the full 3D Solaria 

model. 



Edit Mesher Parameters button:  This button is used to redefine the parameters used to create the 2D mesh 

as well as the mesh structure though the thickness. 

Length Units:  The length units defined in Model>Units are defined here.  Logical units are Micro-Meters or 

Microns, um for abbreviation. 

 

Mesh Parameters 

 

Hitting the Edit Mesher Parameters brings up the dialog shown below. 

 

 
 

Minimum Angle: This defines the minimum internal angle of the triangles created by the mesher.  This value 

should not be changed from 25 degrees as highly skewed triangles can be generated. 

 

Maximum Edge Length: This defines the maximum edge length of a triangle generated by the mesher.  This 

defines the maximum size of triangles that are generated that are not constrained by geometry.  Essentially 

this defines the overall maximum mesh size.  In microns, a value like 100 or 200 is typically good. 

 

Equivalence Tolerance: This is used when cleaning the model, removing Nodes and therefore geometry 

smaller than this value.  Therefore, this value should be at least 10 times smaller than any geometry in the 

model.  For instance, if the Gate Length is 0.25 microns, then this value should be smaller than 0.025.  0.001 is 

a good value. 

 

Geometry Tolerance: This is used by the mesher to clean very small geometry.  It again should be at least ten 

times smaller than any geometry in the model, like Gate Length. 

 

Create mesh lines through device centers: Checking this will create mesh lines through the center of each 

device.  This will make it possible to plot the device temperatures versus location in the Solaria model. 

 

In the main dialog, hitting the Mesh Geometry button creates the 2D mesh as well as the mesh through the 

thickness.  It is visualized on the screen as shown below.   

 



 
Create mesh lines through device centers was not checked. 

 

 
Create mesh lines through device centers has been checked. 

 

If you double click on the screen you can select the XZ button to view a side view showing the mesh through 

the thickness, shown below.  If a value is changed, hit the Clear Existing Mesh then again hit the Mesh 

Geometry button. 

 
Display of the mesh structure through the thickness. 

 

 



The following two settings will affect the mesh through the thickness of the device. 

 

Die mesh factor: This is a factor you can change that affects the mesh of the die through its depth.  You can 

see that the mesh is finer at the die surface.  The factor must be between 1.1 and 2.0. 

 

Layer mesh factor: This is a factor you can define that affects the mesh of the layers through their depth.  The 

factor must be between 0.5 and 4.0. 

 

The option is provided to either build the entire model, half the model or a quarter model.  Many times there 

is thermal symmetry therefore not requiring a complete model for accurate results.   

 

 

 

 
Quarter model showing the chip and one Layer. 

 
Half model of geometry shown on the right. 

 

 



General graphics 

 

As geometry is defined, the 3D geometry is automatically displayed.  The geometry can be revolved and 

zoomed dynamically. 

 

 
Rotate dynamically in wireframe or solid view. 

 

 
Devices can be any orientation.  Vias and Surface Metal can be associated with a Device so they are moved 

and rotated with the Device. 

Vias 
Surface 

metallization 



 
In transparent mode, View>Toggle>Transparent, you can see into the geometry. If you can’t see through the 

materials, go to Settings>OpenGL>Display and change the value for GL Transparency.  A value of 0.15 usually 

works well. 

 

If you have defined plating on any Layers, they can be viewed in transparent mode.  In the figure below, the 

top of both Layers are gray indicating Plating. 

 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



Define Layers 

 

Layers can be added to the model, though they are not required.  Any number of layers can be added.  Layers 

are uniform over the area defined.  Hitting the Add button in the Layer area brings up the following dialog. 

 

  
 

Name: A name is defined for the Layer. 

Material: A material is selected from a library. 

Thickness (Z dimension): The thickness of the Layer is defined. 

Width (X dimension): The width or the X dimension of the Layer is defined. 

Length (Y dimension): The length or the Y dimension of the Layer is defined. 

X location: The offset in the X direction from the origin is defined. 

Y location: The offset in the Y direction from the origin is defined. 

Location Reference: This defines whether the X location and Y location is respect to the center of the Layer or 

the lower left corner of the Layer. 

 



 
Adding Plating to a Layer 

 

To add plating to the top or bottom surface of a Layer, first hit the Add Plating button.  Select the material for 

the plating from the Material drop down list.  Enter the plating thickness in the defined units.  Select the Layer 

from the Layer list then define whether the plating is on the top or bottom side of the layer. 

 

 
 

 

 

 

 

 

 

 

 

Layer 1 

Layer 2 

Chip 



Over mold 

 

Over mold can be defined by checking the Include checkbox in the Over Mold area of the main dialog.  Hitting 

the Edit button brings up the following dialog. 

 

 
 

Material: A material is selected from a library. 

Thickness: This defines the total thickness of the over mold. 

Width: This defines the width in the X direction. 

Length: This defines the length in the Y direction. 

Base at Layer: This defines where the bottom of the over mold goes to.  It is defined relative to a defined 

layer.  The Z location can be defined by the top or the bottom of the layer. 

Location Reference: This defines whether the over mold location is centered on the chip or the lower left 

corner of the chip. 

 

When changes are made, the screen graphics are automatically updated.  What you see on the screen will be 

exactly as in the Solaria model built. 

 

 



 
Thermally conductive pad under the chip, exposed to the bottom. 

 
 

Define amplifier stage (devices) 

 

Hitting the Add button in the Devices area brings up the dialog shown below. 

 

 
 



Device Identifier: This is a name given to the device.  It should be unique. 

Number of Gates per Bank: This defines how many Gates there are for each Bank defined. 

Number of Banks: This defines how many Banks are to be generated.  Each Bank will be exactly the same.  If 

Banks are different then they should be created individually. 

Total Current per Bank (mA): This is the Current draw per bank in milliamps. 

Device Voltage (V):  This is the supplied Voltage. 

Gate Pitch (Const/Variable): This defined the pitch of the Gates.  If they are constant, then the same value 

should be entered for both.  If they alternate, then the two pitches should be entered. 

Bank Pitch: This defined the pitch of the Banks.  This is not used if there is only one Bank. 

Gate Width (Y dim):  This defines the width of the Gates.  This is the long, Y dimension. 

Gate Length (X dim): This defines the length of the Gate.  This is the short, X dimension. 

X Location: This defines the X or horizontal location of the device. 

Y Location:  This defines the Y or vertical location of the device. 

Location Reference: This defines whether the X location and Y location is respect to the center of the chip or 

the lower left corner of the chip. 

Angle: The Device can be rotated to any angle. 

 

Source and Drain metal: 

 

If the Device has Source and Drain metallization, then check Has Source and Drain metallization. 

 

Source Metal thickness: This defines the thickness of the Source metal. 

Drain Metal thickness: This defines the thickness of the Drain metal. 

Source to Gate gap: This defines the space between the Source and the Gate.   

Calculated Source/Drain Width:  This value is automatically calculated based on the data entered. 

Source and Drain Metal Material: A material is selected from a library. 

Has Source Vias: Checking this checkbox will automatically create vias under the X-Y center of each Source 

Metal. The geometry of each via is based on the existing via selected from the drop down to the right.  This is 

shown below.  Also shown are alternating widths of the Source and Drains.  To the right of this checkbox is a 

dropdown list of existing Vias.  A Via must be referenced that defines the geometry of the Via. If there are only 

Source Vias on the chip, then in the Via definition dialog, check Disable Via.  When disabled, the via will not be 

drawn to the screen and it will only be generated at the Source Vias. 

 

 
 

 



 
Uniform and non-uniform gate pitch. 

 

Air bridges  

 

Air bridges can be created between the source metallization.  If there are air bridges, check the Include 

checkbox in the Air Bridge area of the main dialog.  Hitting the Edit button brings up the dialog shown below. 

 

 
 

Material: The air bridge material is selected from the Material library drop down. 

Thickness:  This defines the thickness of the air bridges. 

 

 
 

Note that the graphics show the air bridges floating over the gates.  In the model they are attached to the 

Sources and Drains. 

 

 

 



Vias 

 

Any number of vias can be defined.  They are defined in the Vias area of the main dialog. 

 

Plating Material: The plating material is selected from the Material Library drop down. 

Plating Thickness: The thickness of the vias are defined. 

Filled: If the vias are filled, the Filled is checked and the fill material is selected. 

 

 
 

Hitting the Add button in the Vias area of the main dialog brings up the dialog shown below. 

 
 

Name: This should be a unique name given to the dialog. 

Circular/Rectangular: select whether the via is circular or rectangular. 

Diameter: If Circular is selected then the via diameter is entered. 

Width (X direction): If Rectangular is selected, enter the width of the via. 

Length (Y direction): If Rectangular is selected, enter the length of the via. 

X location: Enter the X location of the via. 



Y location:  Enter the Y location of the via. 

Location Reference: This defines whether the X location and Y location is respect to the center of the via or 

the lower left corner of the via to the chip. 

Cell Reference: The via location can be defined with respect to a device or cell, not the chip.  If a cell or Device 

is selected then if the device is moved or rotated, the via will also. 

Disable Via: If the only Vias on the chip are Source Vias, then this Via should be checked as Disabled.  The only 

purpose for this via is to define the geometry for the Source vias. 

 

 

 

 
Vias can be round and square. 

 
Model of a filled via.  The fill material is dark blue and the plating material is orange.  The light blue is the chip 

and the red is the die attach. 

 

 

 

 

 

 

 

 

 

 

 



Surface metallization 

 

Surface metallization, other than Source and Drain, is defined in the Surface Metallization area of the main 

dialog. 

 

 
 

 

Hitting the Add button will bring up the dialog shown. 

 

 
 

Name: A unique name should be given to the surface metallization. 

Material: A material is selected from the Material library. 

Thickness (Z dimension): The thickness of the surface metallization is defined. 

Width (X dimension): The width or X dimension is defined. 

Length (Y dimension): The length or Y dimension is defined. 

X location: Enter the X location of the surface metallization. 

Y location:  Enter the Y location of the surface metallization. 

Location Reference: This defines whether the X location and Y location is respect to the center of the chip or 

the lower left corner of the chip. 

Cell Reference: The surface metallization location can be defined with respect to a device or cell, not the chip.  

If a cell or Device is selected then if the device is moved or rotated, the surface metallization will also. 

 

 

 

 

 



Examples 

 

2 Source vias with Air Bridges 

 
 

Dark blue surface metallization used to connect the top of the via with the Sources. 

 
 

 
 

Building the Solaria model 

 

First hit the Edit Mesher Parameters button to review the settings.  Next hit the (1) Mesh Geometry button.  

You will be notified when it is done.  The 2D triangular mesh will be drawn to the screen, as shown below. 

 



 
 

2 micron gate length 

 
 

 

 

 



 

1 micron gate length 

 

 

 

 
 

 

 
After hitting the Mesh Geometry button, you can view the 2D mesh and change a mesh parameter if it isn’t 

acceptable.  Hit the Clear Existing Mesh button to remove the existing mesh. 



 
You can also view the mesh through the thickness before building the Solaria model.  Double click on the 

screen to bring up the following dialog.  Hit the XZ button to see a side view of the device then hit Close. 

 

 
 

 

 

Die mesh factor (1.1-2.0): This value can be changed to change the mesh through the thickness of the chip.  It 

must be between 1.1 and 2.0. 

Layer mesh factor (0.5-4.0): This value can be changed to change the mesh through the thickness of the Layer, 

if there are any defined. 

 



 
 

Create the Solaria model 

 

When everything has been defined and the X-Y mesh and the Z mesh are acceptable, hit the (2) Create Solaria 

Model button.  The dialog below will come up.  If you had a Solaria model on the screen and wish to merge 

the amplifier model with it, then this dialog is used to define an offset to the amplifier model.  Otherwise 

simply hit the Apply button with no changes. 

 

 
 

 

When the model is built, you will be notified.  In the main dialog, hit the OK button to go back to the Solaria 

model view.  It may be necessary to hit the View>Reset OpenGL Viewport to resize the model on the screen.   

 

You are now looking at the ready to solve Solaria model.  Hit the  button to solve using the Finite 

Difference solver.  It should solve very quickly, seconds.  If for some reason it takes some time, you can hit the 

 button to use the GCG solver. 

 



 

 
 

 

 

 

 



 
 

Applied Power Depth 

In the example below, the Applied Power Depth was defined at 0.5 microns.  In the picture, the light blue is 

the chip, the dark blue and peach are the Source and Drain metal.  The green is the heat source which you can 

see is 0.5 microns below the surface. 

 



 
Gate heat below the chip surface 

 
Source and drain metallization with Surface Metallization at the left and right sides connecting the Source vias 

to the Source metal. 

 

 
Vias 

 



 
A single via 

 

 
 



 
Zoomed in showing the chip attach material. 

 

Air Bridge representation in the Solaria model 

 

The picture below shows only Source metal (green) and air bridges (yellow).  The air bridge elements actually 

lie on the same plane as the Source and Drain metallization.  But because the air bridges are only one element, 

they only make thermal contact to the Source metal. 

 

 


