
Merging the Chassis and PCB 

Importing the MCAD meshed model into Solaria 

Launch Gmsh then select File>Open then select Chassis.stp. 

 

 

Expand Mesh then select 3D. 

 

Select Refine by splitting. 



 

Select File>Save Mesh. 

In Solaria, select File>Import Geometry>Gmsh mesh.  We only want 3D elements so uncheck 2D 

Elements.  Hit Import then select the file just generated. 

Changing the chassis units from millimeters to inches 

It was noticed that the stl file units were in millimeters so they needed to be changed to inches to 

agree with the PCB model. 

Select Edit>Scale 

Enter 0.03937 for the X, Y and Z factors (note that you can copy and paste) 

Hit Select and box in the entire model 

 

Define model units 

• Select Model>Units 

• Use the Predefined dropdown list to select the units to be used.  They 

should be inches, Joules, seconds, pounds and Celsius. 

 

 

Define a material for the chassis 



• Select Information>Element or the  toolbar button.  Hit Select then click on an 

element in the model. You can see the element references Property 1.  Close the dialog. 

• Select Information>Property 

o Double click in the Property 1 area. 

o Enter Chassis for the Property Name 

o Hit the Edit Material button 

o Select Al Alloy 6061-T6 from the Material Library dropdown list. 

o Select the black Property Color box to change the material color. 

o Close the Material and Property dialogs. 

o Back in the Information Properties dialog you can see that there are many properties that 

are not referenced. They were created for the 2D elements that were not imported.  Hit the 

Clear button then hit Yes to the next dialog. 

o Close the dialog. 

 

Define IntelliMesh Master surfaces in the chassis model 

In Solaria, IntelliMesh Master surfaces need to be added along the card guides, where the PCBs 

make thermal contact.  IntelliMesh is being used to thermally connect two different models with 

different meshes. 

 

Select Add>IntelliMesh 

Hit the Get Surfaces button 

Select the drop-down list under Select Surface.  

Using the down arrow on the keyboard, keep clicking until the surface shown is highlighted. 

When it is, hit the Process button.  This will create IntelliMesh Master elements to the highlighted 

surface. 



  

Again, select the drop-down list and click down to surface 17 then hit Process 

 

Again, select the drop-down list and click down to surface 21 then hit Process 

 

Again, select the drop-down list and click down to surface 25 then hit Process 

 

Add Interface elements on the bottom of the chassis to a fixed temperature coldplate 

Select Add>Interface>Extrude Surface 

Hit Add Property and enter a Temperature of 25C, a heat transfer coefficient of 0.1 and a Property 

name of “Interface to baseplate”. Hit OK to close the dialog. 

Change the Thickness to 0.1”. 

Select Get Surfaces 

From the drop-down list, select the surface that highlights the chassis bottom, as shown. 

Hit the Process button. 

 



 

Double click anywhere on the screen.  Select the ZY button the hit Close. 

 

Select  toolbar button and window in on the lower right corner of the model.  The red 

elements below are the Interface elements just generated. Apparently, the tetrahedron elements don’t 

follow the right hand rule and were extruded in the wrong direction. 

 

Put the Interface elements in a Group 

• Select Group>Quick Group 

• Hit the Property button then check the Interface to baseplate Property. Hit the Hide button. 

• Hit the Process button under the Property button.  Hit Close. 

• Select  

Move the top nodes down in the negative Y direction twice the element thickness, 0.2 inches. 

• Select Edit>Copy and Move 



o Check Move nodes 

o Hit the Select button then box in the top nodes as shown below. 

 

o Hit OK to close the dialog. 

• Select Group>Echo All 

Add boundary nodes to the Interface elements 

• Select Add>Boundary Nodes 

o Select the Interface to baseplate Property. 

o Hit Select then box in the bottom most nodes. 

o Close the dialog. 

 

Create the PCB in SolariaPCB 

 

The PCB below was generated by SolariaPCB by importing an ODB++ file.  The board is cooled by 

using an aluminum frame bonded to the backside of the board.  The frame extends beyond the board 

outline on the top and bottom.  Wedgelocks in the extended area clamp the board to the chassis. This 

was added to the SolariaPCB model using the Wedgelock Edge Contact feature.  Note that the 

Define edge temperature checkbox in not checked.  In this case, IntelliMesh Slave surfaces will be 

created in the thermal contact areas. 

 

 



 

 

Merge the chassis model with the PCB model 

o With the chassis model on the screen, select File>Open Model. 

o Select the file PCB. 

o When asked if you want to merge the model with the current model, hit Yes. 

o In the Merge Models dialog, enter 20 for the X translation.  This will ensure that the two don’t go 

on top of each other. Hit the Apply button.  Hit Yes to the next three dialogs. 

 

Put the chassis and the PCB into Groups 

• Select Group>Edit 

o Select Group number 2 

o Hit the Clear button to make sure nothing already exists in the group. 

o Hit Select then box in the chassis model. 

o Enter Chassis for the group name at the top. 

o Now select Group number 3 

o Again, hit Select then box in the PCB.   



o Enter PCB for the Group name.  

o Close the dialog. 

Now the PCB needs to be rotated then moved into place in the chassis.  A gap is needed between 

the Master and Slave IntelliMesh surfaces, less than the IntelliMesh tolerance. 

Select Modify>Auto Move Objects.  The dialog shown below will come up.  First select the Group 

that is fixed, in this case the chassis, then select the Group that will move, in this case the PCB.  

Once they are selected, hit the Create Groups button.   

 

 

Each group of IntelliMesh surfaces will automatically be shown with their given names.  If the name 

starts with F, then it is a Fixed IntelliMesh group.  If the name starts with M, then it is a Moving 

IntelliMesh group.  Next, from the Moving and Fixed drop down, select which Moving IntelliMesh 

surface should match up with the Fixed IntelliMesh surface.  In this example we are selecting two 

pairs.  Pair up F-M-G 4 with M-S-G 5 and F-M-G 3 with M-S-G 6. 

 



Next hit the Move Object button.   

Close the dialog then solve the model. 

 

 

The following describes the Move Object process. 

First the moving object, in this case the PCB, is rotated so it is on the same plane as the chassis 

IntelliMesh surfaces.  

It does this by: 

1) The centers and overall dimensions of the IntelliMesh Groups are calculated. 

2) It determines what planes the Fixed and Moving IntelliMesh surfaces are on by determining 

what dimension is zero.  For instance, if it is on the XY plane then the Z dimension or thickness 

of the nodes defining the IntelliMesh surfaces must be zero. 

3) Next, the normal direction is determined for each InteliiMesh Group.  This is based on the 

element face the IntelliMesh surfaces lies on.  When the Master and Slave surfaces are 

aligned, the normal must be pointing towards each other.  This therefore goes into determining 

the rotation, positive or negative. 

4) The geometric center of the moving object is calculated 

5) The Moving Group is then rotated onto the correct plane. 

Next, if necessary, the PCB is rotated on plane to align the Master and Slave surfaces.  

This is done by: 

1) The centers and overall dimensions of the IntelliMesh Groups are recalculated because they 

have changed because of the first rotation. 

2) The geometric center of the moving object is recalculated 

3) If two pairs of IntelliMesh Groups were selected, then: 

a. A line connecting the centers of the Fixed pair is compared to a line connecting the 

centers of the Moving pair.  If they are both horizontal or both vertical then which end 



the first pair is on is used to determine if the Moving Group needs to be rotated 180 

degrees. 

b. If the lines are normal to each other, the Moving Group is rotated 90 degrees.  Which 

end the first pair is on is used to determine if the rotation is positive or negative. 

4) If one pair of IntelliMesh Groups were selected, then: 

a. A check is made to see if the long and short dimensions of the Fixed and Moving 

IntelliMesh groups are aligned.  If they are not, then the Moving group is rotated 90 

degrees. 

b. If a 90 degree rotation is needed, then the distance between the center and left and 

right edges of the Moving and Fixed IntelliMesh groups are compared to determine if 

the rotation should be negative or positive.  Note that if there is symmetry in the 

IntelliMesh groups and there is not symmetry in the Moving object then it may be 

necessary to rotate the Moving object manually. 

5) The Moving Group is rotated on the plane to the correct orientation. 

The Moving Group is next moved into place.  This is done by: 

1. The centers and overall dimensions of the IntelliMesh Groups are recalculated because they 

have changed because of the first rotation. 

2. The geometric center of the moving object is recalculated 

3. The centers of the first pair are used to get the X, Y and Z displacement.  

4. The direction normal to the plane is adjusted to create a gap of half the IntelliMesh tolerance 

defined in the dialog. 

5. The Moving Group nodes are then moved. 

The PCB is then automatically moved into place.  All you have to do now is solve for temperatures. 

 

Example 2 – Simple single pair 

Below is a simple example of a PCB, green, and a device, red.  The blue area on the PCB are 

Interface elements with Slave IntelliMesh on their surface.  The bottom side of the red area has 

Master IntelliMesh on the underside surface.   

 

 

 



 

Select Modify>Auto Move Objects then select the Fixed Group, the PCB, then select the Moving 

Group, the Device then hit the Create Groups button.  Notice that the Moving and Fixed groups are 

automatically selected correctly since there is only one of each. 

 

 

Hit the Move Object button. 

 

 



 

All you have to do now is solve for temperatures. 

 

Example 3 – Complex shapes 

Below shows a tetrahedron meshed chassis and a PCB that was created by SolariaPCB. 

 

 

Chassis        PCB 

The left picture below shows the chassis, red, with IntelliMesh surfaces, purple.  On the underside of 

the PCB on the right are IntelliMesh surfaces. 



 

Chassis      PCB 

The goal is to rotate and move the PCB into the correct place within the chassis. 

 

 

Chassis and PCB merged 

 

 

 

 

 

 

 

 



In the Auto Move Objects dialog, the Housing and PCB Groups were selected then the Create 

Groups button was hit.  Since there is only one Move IntelliMesh group, it was automatically 

selected.  IntelliMesh group F-S-G-2 was selected for the Fixed group.  The IntelliMesh group name 

is located at the geometrical center of the IntelliMesh, therefore at the center of the PCB.  The Move 

Object button was next hit. 

 

It is obvious from the picture below that the in-plane rotation based on the logic given earlier was 

incorrect.  But the IntelliMesh are facing each other correctly and they are the correct distance apart.  

The PCB just needs to be rotated about the Y axis positive 90 degrees.  This is easily done manually. 

 

 



 

Display only the PCB Group.  Now select Edit>Copy and Rotate.  Select Rotate about the Y axis 

and enter 90 degrees for the rotation.  Be sure to check Rotate Nodes.  Now check Select Rotation 

Axis and then click on a node at the center of the PCB.  Hit the Select button the box in the entire 

PCB.  When you view the entire model, you will probably see something like that below.  It will be 

rotated differently depending on the node selected. 

 

Now the PCB needs to moved very slightly.  There is a little know feature in Solaria called Edit>Grab 

and Pull.  It is used to select Nodes and manually, using the mouse, move the nodes selected.  

Since we can visually see where the PCB needs to be, it is perfect for this operation. 

Put into a Group just the PCB.  Select Edit>Grab and Pull.  Hit the Select button and box in the 

PCB.  Now view the entire model by selecting Group>Echo All, while leaving the Grab & Pull dialog 

up.  Hold the left mouse button down and slowly and carefully drag the PCB into place, resulting in 

yellow around the PCB as shown below. 

 



 


